万物公式网是一个专注于股票软件、股票公式资源分享的平台
微信公众号:万物狙击

网站首页 > 通达信公式 > 通达信主副图指标 正文

通达信AI底选股指标公式源码[万物公式]

admin 2024-04-02 08:06:07 通达信主副图指标 32 ℃ 0 评论

J1:=-49.00;

显示资金条件:=vol>0 OR MINUTE!=0;

N日内:=89;

统计大阳天数:=1;

原DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

原DEA:=EMA(原DIF,9);

原macd:=(原DIF-原DEA)*2;

MACD金叉:=crOSS(原DIF,原DEA);

SJ:=PERIOD>1;

SHORT:=IF(SJ,12,18);

LONG:=IF(SJ,26,38);

MID:=IF(SJ,9,SQRT(SHORT*LONG)/2);

MACD基准:=100;

BG:=BARSCOUNT(CLOSE);

LL:=LLV(L,12);

HH:=HHV(H,12);

CCM:=CLOSE;

RSV:=(CCM-LL)/(1.001*HH-LL)*MACD基准;

RSV_JGL:=IF(BG>0,RSV,50);

KK:=SMA(RSV_JGL,4,1);

DD:=SMA(KK,3,1);

DIF%:=(EMA(RSV_JGL,LONG)-MACD基准/2);

DEA%:=EMA(DIF%,MID);

MACD%:=2*(DIF%-DEA%);

原RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50-25;

K%:=SMA(原RSV,3,1);

D%:=SMA(SMA(原RSV,3,1),3,1);

J:=3*K%-2*D%;

kd金叉:=CROSS(K%,D%);

MACD顶:=CONST(HHV(MAX(DIF%,MACD%),BARSSINCE(C)));

MACD底:=IF(CONST(LLV(MIN(DIF%,MACD%),BARSCOUNT(C)))>=0,CONST(LLV(MIN(DIF%,MACD%),BARSCOUNT(C)))/2,CONST(LLV(MIN(DIF%,MACD%),BARSCOUNT(C))));

KD顶:=CONST(HHV(MAX(K%,D%),BARSSINCE(C)));

KD底:=IF(CONST(LLV(MIN(K%,D%),BARSCOUNT(C)))>=0,CONST(LLV(MIN(K%,D%),BARSCOUNT(C)))/2,CONST(LLV(MIN(K%,D%),BARSCOUNT(C))));

MCKD顶:=CONST(HHV(MAX((MACD顶+KD顶)/2,MACD%),BARSSINCE(C)));

MCKD底:=CONST(LLV(MIN((MACD底+KD底)/2,MACD%),BARSSINCE(C)));

JJD:=(HIGH+LOW+CLOSE)/3;

KVAR2:=REF(LOW,1);

KVAR3:=SMA(Abs(LOW-KVAR2),3,1)/SMA(MAX(LOW-KVAR2,0),3,1)*MCKD顶;

KVAR4:=EMA(KVAR3*10,3);

KVAR5:=LLV(LOW,13);

KVAR6:=HHV(KVAR4,13);

KVAR7:=EMA(IF(LOW<=KVAR5,(KVAR4+KVAR6*2)/2,0),3)/618;

KVAR8:=IF(IF(KVAR7>500,500,KVAR7)< ABS((MCKD顶-MCKD底)/2)*0.5,IF(KVAR7>500,500,KVAR7),ABS((MCKD顶-MCKD底)/2)*0.5);

XG:KVAR8>1 AND JJD>REF(JJD,1) AND REF(JJD,1)< REF(JJD,2);

更多精彩内容,请关注公众号:万物狙击

其他说明

1、在下载过程遇到问题,请您 联系客服:QQ:2180737354 或 微信1:bsqj88886或者备用微信:bsqj88887 ,我们会在第一时间修复和反馈。
2、本站所提供的股票指标等资源仅供参考学习交流,没稳赚的指标,赢亏自负,如果觉着指标好用请支持正版,否则产生的一切后果将由下载用户自行承担,有部分股票指标资源为网上收集或仿制而来,若模板侵犯了您的合法权益,请来联系我们,我们会及时删除,给您带来的不便,我们深表歉意!

⇒⇒⇒点击加入通达信指标公式交流群QQ群

 

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论: