万物公式网是一个专注于股票软件、股票公式资源分享的平台
微信公众号:万物狙击

网站首页 > 通达信公式 > 通达信主副图指标 正文

通达信跟庄量化指标公式[万物公式]

admin 2024-04-02 08:07:14 通达信主副图指标 38 ℃ 0 评论

VAR1:=90+(100-90)/2;

VAR2:=(100-90)/2;

VAR3:=COST(VAR1);

VAR4:=COST(VAR2);

VAR5:=(VAR3-VAR4)/(VAR3+VAR4)*100/2;

VAR6:=MA(VAR5,3);

VAR7:=IF(VAR6>REF(VAR6,3) AND MA(C,20)>REF(MA(C,20),3),1,0);

STICKLINE(VAR7>0,0,-VAR6,2.1,0),COLOR0064FF;

STICKLINE(VAR7>0,0,-VAR6,1.5,0),COLOR0093FF;

STICKLINE(VAR7>0,0,-VAR6,0.9,0),COLOR00C2FF;

STICKLINE(VAR7>0,0,-VAR6,0.3,0),COLORYELLOW;

VAR8:=(-IF(VAR6>REF(VAR6,3) AND MA(C,20)>REF(MA(C,20),3),1,0))*100;

VAR9:=EMA(EMA(C,9),9);

VAR10:=(VAR9-REF(VAR9,1))/REF(VAR9,1)*500;

STICKLINE(VAR10<0,VAR10,0,3,0),COLOR008000;

VAR11:=crOSS(VAR10,0);

STICKLINE(VAR10>REF(VAR10,1) AND VAR10>0,VAR10,0,3,0),COLORRED;

机构控盘:IF(VAR10>REF(VAR10,1) AND VAR10>0,VAR10,0),NODRAW,COLORRED;

VAR12:=100*WINNER(C*0.95);

STICKLINE(VAR12>50 AND COST(85)>10,VAR10,0,3,0),COLORMAGENTA;

机构高度控盘:IF(VAR12>50 AND COST(85)>20,VAR10,0),NODRAW,COLORMAGENTA;

STICKLINE(VAR10,VAR10,0,3,0),NODRAW,COLORYELLOW;

VAR13:=IF(VAR10,VAR10,0);

机构撤退:IF(VAR10<0,VAR10,0),NODRAW,COLORGREEN;

机构试盘:IF(VAR11,666,0),NODRAW,COLORYELLOW;

STICKLINE(机构试盘>0,0,3,1,0),COLORYELLOW;

DRAWICON(机构试盘>0,0.1,9);

散户活跃:机构控盘=0 AND 机构撤退=0 AND 机构高度控盘=0,NODRAW;

STICKLINE(散户活跃=1,(-0.3),2,3,0),COLORBLUE;

VAR14:=FINANCE(42);

VAR15:=DATETODAY(CONST(DATE));

VAR16:=VAR15-VAR14;

VAR17:=DAYTODATE(VAR16)+19000000;

VAR18:=STRCAT(1475,CON2STR(VAR17,0));

VAR19:=STRCAT(1476,CON2STR(FINANCE(42),0));

VAR20:=STRCAT(VAR19,48);

VAR21:=STRCAT(1477,CON2STR(TOTALBARSCOUNT,0));

VAR22:=STRCAT(VAR21,1478);

VAR23:=EMA(C,1);

VAR24:=VAR23/REF(VAR23,1)>=1.095;

VAR25:=COUNT(VAR24,BARSSINCE(VAR24)+1);

VAR26:=STRCAT(1479,CON2STR(CONST(BARSLAST(VAR24)),0));

VAR27:=STRCAT(VAR26,1480);

VAR28:=STRCAT(1481,CON2STR(VAR25,0));

VAR29:=STRCAT(VAR28,1482);

VAR30:=STRCAT(VAR20,VAR29);

VAR31:=STRCAT(VAR30,VAR27);

VAR32:=STRCAT(1483,VAR31);

VAR33:=IF(CODELIKE(1169),0,1);

VAR34:=vol/CAPITAL*100;

VAR35:=(H+L+C)/3;

VAR36:=VOL/IF(H=L,4,H-L);

VAR37:=IF(CAPITAL=0,VAR36*(VAR35-MIN(C,OPEN)),VAR36*IF(H=L,1,MIN(OPEN,C)-L));

VAR38:=IF(CAPITAL=0,VAR36*(MIN(OPEN,C)-L),VAR36*IF(H=L,1,VAR35-MIN(C,OPEN)));

VAR39:=IF(CAPITAL=0,VAR36*(H-MAX(OPEN,C)),VAR36*IF(H=L,1,H-MAX(OPEN,C)));

VAR40:=IF(CAPITAL=0,VAR36*(MAX(C,OPEN)-VAR35),VAR36*IF(H=L,1,MAX(C,OPEN)-VAR35));

VAR41:=(VAR37+VAR38-(VAR39+VAR40))/IF(CAPITAL=0,10000,10000);

VAR42:=SMA(IF(C>=REF(C,1),VAR41,(-VAR41)/100),2,1);

VAR43:=SMA(VAR42*120/FROMOPEN*5,2,1);

VAR44:=SMA(VAR43,5,1);

VAR45:=SMA(VAR44,5,1);

VAR46:=CURRBARSCOUNT=1 AND C

VAR47:=REF(VAR42,1)-VAR46;

VAR48:=VAR42*1.01-REF(VAR42,1);

VAR49:=REF(VAR42*1.01,1)-REF(VAR42,2);

VAR50:=VAR48>3*Abs(VAR49);

VAR51:=EMA(VAR42,15);

VAR52:=COST(85);

VAR53:=COST(15);

VAR54:=VAR52-VAR53;

VAR55:=(VAR52+VAR53)/2;

VAR56:=VAR54/VAR55*100<30;

VAR57:=HHV(H,250);

VAR58:=LLV( L,250);

VAR59:=VAR57-VAR58;

VAR60:=VAR55-VAR58;

VAR61:=VAR55

VAR62:=VAR56 AND VAR61;

VAR63:=C/REF(C,1)>1.04;

VAR64:=EMA(100*(C-LLV(L,30))/(HHV(H,30)-LLV(L,30)),3);

VAR65:=VAR64>=75 AND C>0 AND C>OPEN;

VAR66:=FILTER(VAR65 AND VAR62 AND VAR60 AND WINNER(C)>=0.9 AND VAR63 AND C/REF(C,1)>1.092 AND C=H AND C<40 AND VAR33 AND VAR34<20,10);

VAR67:=(2*C+H+L)/4;

VAR68:=LLV(L,5);

VAR69:=HHV(H,5);

VAR70:=EMA((VAR67-VAR68)/(VAR69-VAR68)*100,5);

VAR71:=MA(VAR70,2);

VAR72:=REF(C,1)/REF(C,2)<0.95;

VAR73:=VAR71<20 AND VAR72 AND C>L AND OPEN>L;

VAR74:=C/REF(C,3)<0.95;

VAR75:=REF(VAR74,1)=1 AND C/REF(C,1)>1.025;

VAR76:=VOL>REF(HHV(VOL,10),1) AND NOT(OPEN=C) AND H/C<1.0007;

VAR77:=REF(EVERY(MA(C,5),3),3)>1.8;

VAR78:=COUNT(VAR73=1,3)>0 AND REF(C,1)

VAR79:=VOL/REF(VOL,1)>1.7 AND REF(OPEN,1)<100;

跟庄乾坤:VAR75 AND VAR76 AND VAR77 AND VAR78 AND VAR79;

DRAWTEXT(跟庄乾坤,10,16712),COLORMAGENTA;

STICKLINE(跟庄乾坤,14,12,3.5,0),COLORRED;

STICKLINE(跟庄乾坤,15,14.9,1.7,0),COLORRED;

STICKLINE(跟庄乾坤,20.110001,9.6,0.1,0),COLORRED;

STICKLINE(跟庄乾坤,19.16,9.2,0.3,0),COLORRED;

STICKLINE(VAR66,14,12,3.5,0),COLORA8A8A8;

STICKLINE(VAR66,15,14.9,1.7,0),COLORA8A8A8;

STICKLINE(VAR66,14.9,14.8,1.9,0),COLORA8A8A8;

STICKLINE(VAR66,14.8,14.7,2.1,0),COLORA8A8A8;

STICKLINE(VAR66,14.7,14.6,2.3,0),COLORA8A8A8;

STICKLINE(VAR66,14.6,14.5,2.5,0),COLORA8A8A8;

STICKLINE(VAR66,14.5,14.4,2.7,0),COLORA8A8A8;

STICKLINE(VAR66,14.4,14.3,2.9,0),COLORA8A8A8;

STICKLINE(VAR66,14.3,14.2,3.1,0),COLORA8A8A8;

STICKLINE(VAR66,14.2,14.1,3.3,0),COLORA8A8A8;

STICKLINE(VAR66,14.1,14,3.5,0),COLORA8A8A8;

STICKLINE(VAR66,20.110001,9.6,0.1,0),COLORWHITE;

STICKLINE(VAR66,19.16,9.2,0.3,0),COLORWHITE;

STICKLINE(VAR66,19.120001,8.8,0.6,0),COLORWHITE;

STICKLINE(VAR66,18.799999,18.4,0.9,0),COLORWHITE;

STICKLINE(VAR66,18.4,18,1.2,0),COLORWHITE;

STICKLINE(VAR66,18,15,1.4,0),COLORWHITE;

STICKLINE(VAR66,17.4,17,0.6,0),COLORRED;

STICKLINE(VAR66,16.5,16.4,1.5,0),COLORBLUE;

STICKLINE(VAR66,15.1,14.9,1.5,0),COLORBLUE;

STICKLINE(VAR66,14.9,12.5,1.5,0),COLORWHITE;

STICKLINE(VAR66,12.5,12,1.3,0),COLORRED;

STICKLINE(VAR66,12,11.3,1,0),COLORRED;

STICKLINE(VAR66,11.3,10.7,0.7,0),COLORRED;

STICKLINE(VAR66,10.77,10.1,0.3,0),COLORRED;

STICKLINE(VAR66,12.48,12.18,1,0),COLORYELLOW;

STICKLINE(VAR66,12.18,11.88,0.5,0),COLORYELLOW;

STICKLINE(VAR66,11.88,11.58,0.1,0),COLORYELLOW;

STICKLINE(VAR66,16,15.5,0.5,0),COLORRED;

VAR80:=MA(C,5);

VAR81:=MA(C,144);

VAR82:=(H-VAR80)/VAR80*100;

VAR83:=(H-VAR80)/VAR80*100>=20 AND H>C;

VAR84:=VAR82>=15 AND VAR82<20 AND H>C;

VAR85:=FILTER(VAR84,12);

STICKLINE(VAR83,0,5.8,0,0),COLORGREEN;

STICKLINE(VAR83,5,6,3,0),COLORGREEN;

DRAWICON(VAR83,6,9);

VAR86:=(C-REF(C,1))/REF(C,1)*100;

VAR87:=IF(NAMELIKE(251) OR NAMELIKE(1486),0.05,0.1);

VAR88:=C/REF(C,1)-1>=VAR87-0.01/REF(C,1) AND C=H;

VAR89:=BARSLASTCOUNT(VAR88);

VAR90:=REF(VAR89,1);

VAR91:=REF(VAR88,1) OR REF(VAR88,2);

VAR92:=VOL>=REF(VOL,1)*1.2 AND C>REF(C,1) AND OPEN>REF(C,1);

VAR93:=(C-REF(C,3))/REF(C,3)*100<20 AND (HHV(H,5)-LLV(L,5))/REF(OPEN,5)<0.45 AND (HHV(H,9)-LLV(L,9))/REF(OPEN,9)<0.43 AND (HHV(H,12)-LLV(L,12))/REF(OPEN,12)<0.52 AND (HHV(H,10)-LLV(L,10))/REF(OPEN,10)<0.52;

VAR94:=C>=HHV(MAX(C,OPEN),20) AND (C-REF(C,12))/REF(C,12)*100<30 AND (C-REF(C,13))/REF(C,13)*100<25;

VAR95:=VOL>=REF(HHV(VOL,70),70);

VAR96:=H>=HHV(MAX(C,OPEN),60) AND (C-REF(C,70))/REF(C,70)*100<150 AND SUM(VOL/CAPITAL*100,12)<150;

VAR97:=VAR92 AND VAR93 AND VAR96 AND VAR95;

STICKLINE(VAR97,0,1,2,0),COLORGREEN;

更多精彩内容,请关注公众号:万物狙击

其他说明

1、在下载过程遇到问题,请您 联系客服:QQ:2180737354 或 微信1:bsqj88886或者备用微信:bsqj88887 ,我们会在第一时间修复和反馈。
2、本站所提供的股票指标等资源仅供参考学习交流,没稳赚的指标,赢亏自负,如果觉着指标好用请支持正版,否则产生的一切后果将由下载用户自行承担,有部分股票指标资源为网上收集或仿制而来,若模板侵犯了您的合法权益,请来联系我们,我们会及时删除,给您带来的不便,我们深表歉意!

⇒⇒⇒点击加入通达信指标公式交流群QQ群

 

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论: